Finalmente, suporte a PHP 5.5 com o WordPress 3.9

Até agora se quiséssemos usar o PHP 5.5 com o WordPress tínhamos um festival de erros se não fosse usado um plug-in que permitisse o acesso ao MySQL por mysqli ou PDO. Com o WordPress 3.9 isso acabou.

Wordpress

Agora passa a ser possível usar PHP 5.5 com o WordPress 3.9, uma vez que passa a ser usado o mysqli quando as funções mysql não estão disponíveis.

O ideal seria a opção pelo PDO para que no futuro se possa migrar facilmente para MariaDB, Percona, ou MongoDB. Desta forma já passa a ser possível utilizar a última versão do PHP e até ver são raros os plug-ins que continuam a aceder directamente ao MySQL sem usar o wpdb do WordPress.

 
Copyright © 1985 - 2017 Eduardo Maio. Alguns direitos reservados.
eduardomaio.net - Às vezes mais valia ser Agricultor do que Programador
Ao navegar no blog eduardomaio.net está a concordar com os termos legais e de privacidade.